当前位置:首页 > 插件 > 正文

[全版本]ProtocolLib 4.5.0插件前置

某些任务无法使用标准 Bukkit API 执行,并且可能需要直接使用甚至修改 Minecraft。

常见的技术是修改传入和传出数据包或将自定义数据包注入流。但是,这样做相当麻烦,并且大多数实现将在 Minecraft 的新版本发布后立即中断,这主要是因为混淆。

ProtocolLib是一个允许读取和写入对 Minecraft 协议的访问的

库。它处理反射和通道注入所需的大部分开销,并提供包装以简化数据包修改。它更新了大多数Minecraft更新,所以,理想情况下,个别插件不必。协议Lib通常不需要为次要更新进行更新,尤其是在代码更改很少(即 1.8 安全更新)

权限&指令

/protocol    更新插件    protocol.admin  管理员权限

【此版本兼容所有craftbukkit、spigot、mcpc+】

【兼容java6、java7、java8】

 隐藏内容
您未登录,请登录注册后查看
0
您需要 登录账户 后才能发表评论

发表评论